+ Reply to Thread
Results 1 to 5 of 5

Thread: Aqua Rite / no lights at all

  1. #1
    Join Date
    Dec 1969
    Location
    Georgia
    Posts
    9

    Default Aqua Rite / no lights at all

    I have a Aqua Rite chlorine generator that I installed about 4 years ago. I checked yesterday and I have no lights at all, no digital display. When looking online at the Goldline manual, I see that after 10/04 it has a different 20 amp fuse. I have pulled the cover to look at the circuit board, but I'm not sure what I am looking for. I do not see a twist out fuse. Can anyone help with a schematic or a pic that would show where the fuse is and how to replace it.
    The board number is 066012B-1, the cell number is 5E0407-2072274

  2. #2
    tonyl is offline Registered+ Weir Watcher tonyl 0
    Join Date
    Dec 1969
    Location
    Indiana
    Posts
    188

    Default Re: Aqua Rite / no lights at all

    Harley,
    Look for the fuse at the bottom of the control box from the outside.
    Hope this helps.

  3. #3
    Join Date
    Dec 1969
    Location
    Georgia
    Posts
    9

    Default Re: Aqua Rite / no lights at all

    Thanks Tony, I found the fuse and it was blown. I set it to super chlorinate and after about 2 hours looked at it and it was not generating and had a high salt light on. I have not added any salt to it and it was reading 2900. I cut it off and set it to about 70 and it appeared to be working, checked this morning and it was not generating. Again cut off and cut back on and it was showing to be generating chlorine. I will check agian tonight after work. Something is not right though.

  4. #4
    tonyl is offline Registered+ Weir Watcher tonyl 0
    Join Date
    Dec 1969
    Location
    Indiana
    Posts
    188

    Default Re: Aqua Rite / no lights at all

    Harley,
    Could be the cell is dying, but usually the first indication of that is the slow dropping of the salt level indication. Don't know if you're experiencing this or your pool has always been at 2900. Also, you might pull the cell and visually check it.

  5. #5
    Join Date
    Dec 2004
    Location
    .
    Posts
    6

    Default Re: Aqua Rite / no lights at all

    Check out this post I just fixed mine for 5 dollars. It was the inrush currrent limiter on the board. Black disc about the size of a qauter was fried..
    http://www.poolforum.com/pf2/showthread.php?p=57693

+ Reply to Thread

Similar Threads

  1. aqua rite issue or no
    By MUTTS in forum Salt Generators (SWCG) & other Chlorine Feeders
    Replies: 6
    Last Post: 07-03-2012, 01:08 PM
  2. Aqua Rite Question
    By wataka88 in forum Salt Generators (SWCG) & other Chlorine Feeders
    Replies: 2
    Last Post: 07-15-2011, 03:33 PM
  3. Aqua RiteŽ Jr. ?
    By BND in forum Salt Generators (SWCG) & other Chlorine Feeders
    Replies: 4
    Last Post: 04-05-2007, 07:53 PM
  4. New Aqua Rite
    By Simmons99 in forum Salt Generators (SWCG) & other Chlorine Feeders
    Replies: 10
    Last Post: 09-06-2006, 04:01 PM
  5. Aqua-rite Swg
    By DONNIE in forum Using Chlorine and Chlorinating Chemicals
    Replies: 2
    Last Post: 07-31-2006, 09:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts