I had my 12,000 gal pool resurfaced in March. When I turned the Aqua Rite system back on, I had a solid red light for No Flow. I bought a new flow switch which produced the same solid red light. I manually tested both, and they worked. I turned on the water with the switch out and water is gushing out of the hole. I used velcro to keep the flow switch engaged. The power and generating lights both turned on. The salt was reading too low for the system to stay generating. I checked the level manually and there was 3200 salt in the pool. I thought it would balance out once the flow issue was no longer a problem. I checked the salt reading a few days later and it showed 0. I live in FL, so my pool runs all year long. The cell I had was 3.5 years old. It passed the test at the pool store, but from everything I read a bad salt reading is caused by the cell.

I purchased a new cell. I was able to recalibrate the salt level to 500, while my manual test showed 3000. I have tried multiple times to recalibrate it, but the instant reading isn't showing anything higher. I replaced the mother board in June. I don't know what else to check. Is it possible my new cell is defective?

- 0
AL -0
r 1.59