+ Reply to Thread
Results 1 to 10 of 32

Thread: Filter delivers dirty de

Hybrid View

  1. #1
    Join Date
    Dec 1969
    Location
    11727
    Posts
    28

    Default Filter delivers dirty de

    My Hayward Perflex EC65 sends a temporary plume of dirty DE media into the pool thru the eyeball return jets after the 1.5 HP pump has been off for a while. I removed and inspected the rubber gasket and every grid finger and found no damage / tears / holes / cracks. Same for the grid plates, bump shaft o-rings. I even tried replacing the tank check valve. Maybe I should try the fiber type of media instead of DE powder?

  2. #2
    Join Date
    Sep 2014
    Location
    Tucson, AZ
    Posts
    222

    Default Re: Filter delivers dirty de

    Does the filter have a plunger-style backwash valve or a multiport valve?

    I'm thinking maybe there's a leak in your backwash valve...just my opinion FWIW...
    16k gal IG gunite PebbleTec (Caribbean Blue), 18' x 36' free form with raised spa/spillway and separate rock waterfall. All Pentair Equipment pad - 3HP IntelliFlo VS / 1.5HP WhisperFlo, MasterTemp 400k BTU/hr heater, QuadDE-100 filter, IC40 SWCG, IntelliTouch/EasyTouch Controls

  3. #3
    CarlD's Avatar
    CarlD is offline SuperMod Emeritus Vortex Adjuster CarlD 4 stars CarlD 4 stars CarlD 4 stars CarlD 4 stars CarlD 4 stars CarlD 4 stars
    Join Date
    Dec 1969
    Location
    North Central NJ
    Posts
    6,607

    Default Re: Filter delivers dirty de

    I don't know much about DE filters but I do know that changing media won't fix a basic problem. I'm wondering, if in addition to SO's idea, if your pump is rated for a higher output than your filter's input, which is a common problem. A 1.5hp pump CAN be too strong, especially if it's a full-rated pump (most in ground pool pumps are). How big is your pool and what kind of pump is it?

    You can go to Hayward-Pools.com and look up your owner's manual. It has several suggestions of possible causes of DE going back into your pool.
    Carl

  4. #4
    Join Date
    Sep 2014
    Location
    Tucson, AZ
    Posts
    222

    Default Re: Filter delivers dirty de

    +1 to @CarlD !!!

    Yeah, before spouting off I should have asked for more details on the pump/filter combo. I have a full rated, variable speed 3HP IntelliFlo pump. I also have the biggest DE filter possible. Even then, I run my pump on the slowest speed most of the time. I only use the highest speeds for quick vacuuming.

    What kind of pump do you have? Horsepower? Single-, two-, variable-speed?

    What's the sq-ft area of your filter and its nominal flow rate?
    16k gal IG gunite PebbleTec (Caribbean Blue), 18' x 36' free form with raised spa/spillway and separate rock waterfall. All Pentair Equipment pad - 3HP IntelliFlo VS / 1.5HP WhisperFlo, MasterTemp 400k BTU/hr heater, QuadDE-100 filter, IC40 SWCG, IntelliTouch/EasyTouch Controls

  5. #5
    Join Date
    Dec 1969
    Location
    11727
    Posts
    28

    Default Re: Filter delivers dirty de

    Pool - Pacific in-ground vinyl 27,500 gal
    Filter - Hayward Perflex EC65 67 gpm rating with 27 square feet effective filtration area.
    Pump -Hayward Super Pump 1.5 hp single speed rated at 65 gpm with 30 feet of head resistance.
    There is no 'backwash action'. The filter features a bump handle that regenerates the DE by jogging the grid - something like a piston.

  6. #6
    CarlD's Avatar
    CarlD is offline SuperMod Emeritus Vortex Adjuster CarlD 4 stars CarlD 4 stars CarlD 4 stars CarlD 4 stars CarlD 4 stars CarlD 4 stars
    Join Date
    Dec 1969
    Location
    North Central NJ
    Posts
    6,607

    Default Re: Filter delivers dirty de

    Pump: 65gpm with 30' of head.
    Filter: 67 gpm.

    So if you do NOT have at least 30' of head, your pump is probably exceeding your filter's max. In any case, IMHO, the filter is too small for the pump and you need a bigger cap filter or smaller pump.
    Carl

+ Reply to Thread

Similar Threads

  1. Dirty water
    By Lawater in forum Pool Chemistry for Intex-type Pools
    Replies: 3
    Last Post: 07-06-2014, 08:42 PM
  2. Cleaning up a very dirty pool with a DE filter
    By jrtredo in forum Pool Startup, Shutdown, & Winter Operation
    Replies: 6
    Last Post: 06-27-2013, 12:48 PM
  3. Dirty water returns from pump/filter upon startup
    By MJPancoast in forum Pool Equipment & Operations
    Replies: 6
    Last Post: 07-21-2012, 02:26 AM
  4. de filter getting dirty quickly
    By spider22 in forum Pool Equipment & Operations
    Replies: 9
    Last Post: 09-07-2010, 02:57 PM
  5. Why is my pool so dirty!!!
    By bizbad in forum Pool Chemicals & Pool Water Problems
    Replies: 20
    Last Post: 04-26-2007, 05:27 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts