+ Reply to Thread
Results 1 to 3 of 3

Thread: HELP! Replaced pump and the noise is back!

  1. #1
    Join Date
    Mar 2011
    Posts
    1

    Angry HELP! Replaced pump and the noise is back!

    About four months back my 3 year old Sta Rite Dyna Glas 1 HP pump started making a loud noise. It sounded like the pump was grinding rocks or marbles. A friend of mine (who cleans pools) came by about three weeks ago to listen for himself. He thought it was the bearings. With his discount, we decided to replace my motor.

    So about two weeks ago, we replaced the motor. When we replaced the motor we noticed the impeller looked like it had been rubbing against something (possibly the difusser?) but he didnt think it looked bad enough to replace - but then again he doesnt repair pumps.

    After we replaced the pump, it sounded fantastic! But today it started making the noise again. Not as bad or as loud...but it's definatly the noise.

    I turned my skimmer valve off and the noise wasn't as loud. Possibly a clogged line?

    Any ideas what could be causing the issue? Clogged skimmer valve? Bad impeller and or diffuser? A lemon motor?

    Thanks!

  2. #2
    PoolDoc's Avatar
    PoolDoc is offline Administrator Quark Inspector PoolDoc 5 stars PoolDoc 5 stars PoolDoc 5 stars PoolDoc 5 stars PoolDoc 5 stars PoolDoc 5 stars PoolDoc 5 stars
    Join Date
    Jan 2005
    Location
    Georgia
    Posts
    11,385

    Default Re: HELP! Replaced pump and the noise is back!

    Trying to diagnose a motor problem from a bad sound none of us has heard . . . is not a good idea.

    And, even if you recorded and posted the sound, that wouldn't help, because we'd need to be able to match sound with the visually examined source.

    OTOH, if you want to take pictures of the pump parts -- impeller, diffuser, etc. -- and post them somewhere (does Yahoo have some thing like Picasa? -- if not make a Google account, and use Picasa), and give use the URL address, that might help.

    OR, borrow a pump from your friend, connect it temporarily and see if the sound disappears.

    PoolDoc

  3. #3
    Join Date
    Apr 2011
    Posts
    1

    Default Re: HELP! Replaced pump and the noise is back!

    usually its the bearings that have gone bad.
    http://www.aspsvc.com

+ Reply to Thread

Similar Threads

  1. Replaced pump
    By gohogs1 in forum Pool Equipment & Operations
    Replies: 4
    Last Post: 04-06-2012, 03:37 PM
  2. No power to pump? Fuse blown. Replaced & didnt fix
    By topnotch in forum Pool Equipment & Operations
    Replies: 1
    Last Post: 06-28-2011, 12:40 AM
  3. Replies: 7
    Last Post: 04-18-2011, 10:19 PM
  4. Pump noise
    By Phillbo in forum Pool Equipment & Operations
    Replies: 1
    Last Post: 10-13-2006, 07:18 PM
  5. pump noise....
    By amyinraleigh in forum Above-Ground Pool Construction & Repair
    Replies: 5
    Last Post: 07-17-2006, 05:19 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts